In 20 years, you will be more dissapointed by what you didn't do than by what you did.

BGP LAB1 part 1

I created a very simple BGP lab to refresh BGP command and knowledge.





Ip addresses :

R1

Interface IP Address Subnet Mask
Loopback 0 1.1.1.1 255.255.255.255
Loopback 1 11.1.0.1 255.255.255.0
S0/1/0 10.0.12.1 255.255.255.0
S0/1/1 10.0.13.1 255.255.255.0



R2

Interface IP Address Subnet Mask
Loopback 0 2.2.2.2 255.255.255.255
Loopback 1 12.1.0.1 255.255.255.0
s0/0/0 10.0.12.2 255.255.255.0
g0/0 10.0.24.2 255.255.255.0
g0/1 10.0.23.2 255.255.255.0



R3

Interface IP Address Subnet Mask
Loopback 0 3.3.3.3 255.255.255.255
Loopback 1 13.1.0.1 255.255.255.0
s0/0/0 10.0.13.3 255.255.255.0
g0/0 10.0.34.3 255.255.255.0
g0/1 10.0.23.2 255.255.255.0



R4

Interface IP Address Subnet Mask
Loopback 0 4.4.4.4 255.255.255.255
Loopback 1 14.1.0.1 255.255.255.0
fe0/0 10.0.24.4 255.255.255.0
fe0/1 10.0.34.4 255.255.255.0


Tasks :

1) Create BGP neighbor relationship between all routers
   - use BGP peer-group

2) BGP Neighbor MD5 Authentication
3) All routers and all loopback0 must be available to ping



Bellow ready configs :



R1)


controller T1 0/1/0
 cablelength long 0db
 channel-group 0 timeslots 1-24
!
controller T1 0/1/1
 cablelength long 0db
 channel-group 0 timeslots 1-24

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 11.1.0.1 255.255.255.0
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown


interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0:0
 ip address 10.0.12.1 255.255.255.0
!
interface Serial0/1/1:0
 ip address 10.0.13.1 255.255.255.0
!
router bgp 1
 bgp log-neighbor-changes
 network 1.0.0.0
 network 10.0.12.0 mask 255.255.255.0
 network 10.0.13.0 mask 255.255.255.0
 network 172.16.0.0 mask 255.255.255.0
 neighbor BGP_GROUP peer-group
 neighbor BGP_GROUP password TEST
 neighbor BGP_GROUP ebgp-multihop 2
 neighbor BGP_GROUP update-source Loopback0
 neighbor 2.2.2.2 remote-as 2
 neighbor 2.2.2.2 peer-group BGP_GROUP
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 peer-group BGP_GROUP
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 2.0.0.0 255.0.0.0 10.0.12.2
ip route 3.3.3.3 255.255.255.255 10.0.13.3
ip route 4.4.4.4 255.255.255.255 10.0.12.2

!
alias exec s show ip int brief
alias exec r show run
alias exec cpu show processes cpu | e 0.00%  0.00%  0.00%
alias exec bgp show ip bgp summary
alias exec backup copy running-config tftp://172.16.0.2
!

R2)

controller T1 0/0/0
 cablelength long 0db
 channel-group 0 timeslots 1-24
!
controller T1 0/0/1
 cablelength long 0db
 channel-group 0 timeslots 1-24

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
!
interface Loopback1
 ip address 12.1.0.1 255.255.0.0
 !
!
interface GigabitEthernet0/0
 ip address 10.0.24.2 255.255.255.0
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0/1
 ip address 10.0.23.2 255.255.255.0
 duplex auto
 speed auto
 !
!
interface Serial0/0/0:0
 ip address 10.0.12.2 255.255.255.0
 !
!
interface Serial0/0/1:0
 no ip address
 !
!
router ospf 1
 log-adjacency-changes
!
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 network 1.0.0.0
 network 10.0.12.0 mask 255.255.255.0
 network 10.0.23.0 mask 255.255.255.0
 network 10.0.24.0 mask 255.255.255.0
 neighbor BGP_GROUP peer-group
 neighbor BGP_GROUP password TEST
 neighbor BGP_GROUP ebgp-multihop 2
 neighbor BGP_GROUP update-source Loopback0
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 peer-group BGP_GROUP
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 peer-group BGP_GROUP
 neighbor 4.4.4.4 remote-as 4
 neighbor 4.4.4.4 peer-group BGP_GROUP
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 1.0.0.0 255.0.0.0 10.0.12.1
ip route 3.3.3.3 255.255.255.255 10.0.23.3
ip route 4.0.0.0 255.0.0.0 10.0.24.4



R3)


!
controller T1 0/0/0
 cablelength long 0db
 channel-group 0 timeslots 1-24
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 !
!
interface Loopback1
 ip address 13.1.0.1 255.255.255.0
 !
!
interface GigabitEthernet0/0
 ip address 10.0.34.3 255.255.255.0
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0/1
 ip address 10.0.23.3 255.255.255.0
 duplex auto
 speed auto
 !
!
interface Serial0/0/0:0
 ip address 10.0.13.3 255.255.255.0
 !
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 network 10.0.13.0 mask 255.255.255.0
 network 10.0.23.0 mask 255.255.255.0
 network 10.0.34.0 mask 255.255.255.0
 neighbor BGP_GROUP peer-group
 neighbor BGP_GROUP password TEST
 neighbor BGP_GROUP ebgp-multihop 2
 neighbor BGP_GROUP update-source Loopback0
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 peer-group BGP_GROUP
 neighbor 2.2.2.2 remote-as 2
 neighbor 2.2.2.2 peer-group BGP_GROUP
 neighbor 4.4.4.4 remote-as 4
 neighbor 4.4.4.4 peer-group BGP_GROUP
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 1.1.1.1 255.255.255.255 10.0.13.1
ip route 2.2.2.2 255.255.255.255 10.0.23.2
ip route 4.4.4.4 255.255.255.255 10.0.34.4
!

control-plane
 !
!
alias exec s show ip int brief
alias exec r show run
alias exec cpu show processes cpu | e 0.00%  0.00%  0.00%
alias exec bgp show ip bgp summary
alias exec backup copy running-config tftp://172.16.0.2



R4)

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
 ip address 14.1.0.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.24.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.34.4 255.255.255.0
 duplex auto
 speed auto
!
router bgp 4
 no synchronization
 bgp router-id 44.44.44.44
 bgp log-neighbor-changes
 network 10.0.34.0 mask 255.255.255.0
 neighbor BGP_GROUP peer-group
 neighbor BGP_GROUP password TEST
 neighbor BGP_GROUP ebgp-multihop 2
 neighbor BGP_GROUP update-source Loopback0
 neighbor 2.2.2.2 remote-as 2
 neighbor 2.2.2.2 peer-group BGP_GROUP
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 peer-group BGP_GROUP
 no auto-summary
!
ip classless
ip route 2.0.0.0 255.0.0.0 10.0.24.2
ip route 3.3.3.3 255.255.255.255 10.0.34.3
!
no ip http server
no ip http secure-server
!

!
alias exec s show ip int brief
alias exec r show run
alias exec cpu show processes cpu | e 0.00%  0.00%  0.00%
alias exec bgp show ip bgp summary
alias exec backup copy running-config tftp://172.16.0.2
!

Comments

0 Responses to "BGP LAB1 part 1"

Post a Comment

Popular Posts